Android и iOS SDKs для разработчиков мобильных приложений

Свыше 1,500,000 приложений разработано с iOS и Android SDK от iBuildApp

Заказы

Welcome
hot coffee and candy
Здравствуйте уважаемые админы.
Мне хотелось бы создать свое приложение для службы такси. Насчет оплаты можете не беспокоится....
Агентство недвижимости
Добрый день, в принципе устраивает ваш шаблон для недвижимости №6, требуется приложение с...
Мобильное приложение
Разработка мобильного приложения для площадки, с расширенным функционалом.
нужно приложение, которое после запуска, сразу открывает “браузер”
Мне нужно приложение, которое после запуска, сразу открывает "браузер" в приложении и запускает...

Системные требования

Здесь разработчики могут создавать, развивать, тестировать и публиковать свои собственные Виджеты для мобильных приложений на базе платформы iBuildApp.


Системные требования для iOS

Для того, чтобы запустить iBuildApp Mobile SDK Ваша системная среда должна отвечать следующим требованиям:

  • Операционная система: Mac OS X 10.6.6 и выше
  • Apple xCode and iOS SDK: xCode 4.0.2 & iOS SDK 4.3.2 (рекомендовано) и выше, Xcode 3.2.6 & iOS SDK 4.3 (официально не поддерживается)

Как установить Apple xCode и iOS SDK на Mac или Windows

Разработка виджетов для мобильных приложений iOS на основе платформы iBuildApp требует установки Apple developer xCode и iOS SDK.

Вы можете использовать диск, который поставляется в комплекте с Вашим компьютером для установки Xcode и iOS SDK.

Так же Вы можете скачать самую последнюю версию Xcode и iOS SDK с сайта компании Apple http://developer.apple.com/devcenter/ios/index.action

Для того, чтобы скачать Apple developer xCode with the iOS SDK с сайта компании Apple, Вы должны быть подписчиком программы разработчиков Apple.

К счастью, это совершенно бесплатно и Вы можете активировать ее с использованием уже существующей учетной записи Apple (например той, при помощи которой Вы покупаете музыку на iTunes).

Для того, чтобы получить больше информации по загрузке, установке и начале работы с Xcode и iOS SDK обратитесь к документации https://developer.apple.com/support/xcode/


Выберите активную версию Xcode

Зайдите Xcode >> Project, найдите Ваш проект (Название виджета) в левом меню и измените номер iOS Deployment Target на 4.3:

Рис. 1

Рис. 1


Системные требования для Android

Для того, чтобы запустить iBuildApp SDK tool for Android, ваша среда разработки должна удовлетворять следующим условиям:

  • Операционная система: Windows XP/VISTA/7, Linux, Mac OS X
  • JDK 6 & Android developer tool такие как SDK rev. 17

Приведенные ниже инструменты могут быть использованы для разработки с использованием iBuildApp SDK:

  • Консоль;
  • Eclipse IDE 3.6.2 (и выше) & ADT;
  • NetBeans IDE 6.7.0 (и выше) & NBAndroid.

Установка JDK, Android SDK, Eclipse IDE и ADT

iBuildApp requires JDK and Android SDK to be installed in order for you to develop Features for Android applications. For more details on download, installation and getting started with JDK please refer to Oracle official website: http://docs.oracle.com/javase/7/docs/webnotes/install/index.html. For more details on download, installation and getting started please refer to Android official website: http://developer.android.com/sdk/installing/index.html.

For more details on download and installation of ADT Plugin please refer to Android official website: http://developer.android.com/sdk/installing/installing-adt.html

Вы можете получить последнюю версию Eclipse IDE на сайте Eclipse http://www.eclipse.org/downloads/


Выбор активной версии Android

Установите номер Project Build Target равным 8 (Google APIs):

Рис. 2

Рис. 2



Видео для разработчиков мобильных приложений
Видео для разработчиков мобильных приложений